summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-07 14:52:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-05-10 21:42:12 +0200
commit0d4a0d60f17ff20522fcb05dc0dd002951e8b1b7 (patch)
treea29608c9b94dc051c914698a7ea9a1132caf8d61 /gnu
parent439c59da525cb3d52a52dfc02ee12d072a43a4f4 (diff)
downloadguix-patches-0d4a0d60f17ff20522fcb05dc0dd002951e8b1b7.tar
guix-patches-0d4a0d60f17ff20522fcb05dc0dd002951e8b1b7.tar.gz
gnu: Add java-jsr305.
* gnu/packages/java.scm (java-jsr305): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index c2b81556fe..32a7804e72 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1852,6 +1852,29 @@ in the @code{java.lang} package. The following classes are included:
@end itemize\n")
(license license:asl2.0)))
+(define-public java-jsr305
+ (package
+ (name "java-jsr305")
+ (version "3.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://repo1.maven.org/maven2/"
+ "com/google/code/findbugs/"
+ "jsr305/" version "/jsr305-"
+ version "-sources.jar"))
+ (sha256
+ (base32
+ "1rh6jin9v7jqpq3kf1swl868l8i94r636n03pzpsmgr8v0lh9j2n"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:tests? #f ; no tests included
+ #:jar-name "jsr305.jar"))
+ (home-page "http://findbugs.sourceforge.net/")
+ (synopsis "Annotations for the static analyzer called findbugs")
+ (description "This package provides annotations for the findbugs package.
+It provides packages in the @code{javax.annotations} namespace.")
+ (license license:asl2.0)))
+
(define-public java-commons-cli
(package
(name "java-commons-cli")