summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-10 01:05:48 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:01 -0400
commitf880fc7b88f25f9cca59dffabd9de6dd0ab24fc9 (patch)
treed9eb5da1842f324c160241307eb47322e87c6957 /gnu
parent5e25aeee162d88fd2a7c9254a3b3df1783e1b69b (diff)
downloadguix-patches-f880fc7b88f25f9cca59dffabd9de6dd0ab24fc9.tar
guix-patches-f880fc7b88f25f9cca59dffabd9de6dd0ab24fc9.tar.gz
gnu: Add python-lazr-restfulclient.
* gnu/packages/python-web.scm (python-lazr-restfulclient): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d6f068f607..47ba88882f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -109,6 +109,31 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (srfi srfi-1))
+(define-public python-lazr-restfulclient
+ (package
+ (name "python-lazr-restfulclient")
+ (version "0.14.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "lazr.restfulclient" version))
+ (sha256
+ (base32 "11yhlqmdf2cqbdfzn8gdmzvmcivh4fflr18zf412sflvfjrdc3xz"))))
+ (build-system python-build-system)
+ ;; Disable the test suite to avoid the lazr.authentication requirement,
+ ;; which requires the ancient 'oauth', a Python 2 only library.
+ (arguments (list #:tests? #f))
+ (propagated-inputs
+ (list python-distro
+ python-httplib2
+ python-oauthlib
+ python-wadllib))
+ (home-page "https://launchpad.net/lazr.restfulclient")
+ (synopsis "Web client Python library extending wadlib")
+ (description "This package provides a programmable client library that
+adds functionality on top of @code{wadlib}.")
+ (license license:lgpl3+)))
+
(define-public python-lazr-uri
(package
(name "python-lazr-uri")