summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-23 00:21:56 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:19 -0400
commita116f7fdeeb267146d59ff03e148934e7373496d (patch)
tree09762450745a007481012b9b51474fc1fe8f7877 /gnu
parentdf53689c512ac7ff38b270596f0cee0f41d12dfb (diff)
downloadguix-patches-a116f7fdeeb267146d59ff03e148934e7373496d.tar
guix-patches-a116f7fdeeb267146d59ff03e148934e7373496d.tar.gz
gnu: python-astroid: Propagate python-typing-extensions.
* gnu/packages/python-xyz.scm (python-astroid) [native-inputs]: Move python-typing-extensions to... [propagated-inputs]: ... here. [synopsis]: Shorten. [description]: Normalize indentation.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 95fab20247..8e1f0fd807 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19084,21 +19084,19 @@ multitouch applications.")
(base32 "19iiys4233cicpm48fd7lrkm31kk47qiv44wvk952rqbcn4rd2dh"))))
(build-system python-build-system)
(propagated-inputs
- (list python-lazy-object-proxy python-wrapt))
+ (list python-lazy-object-proxy python-typing-extensions python-wrapt))
(native-inputs
- (list python-pytest python-pytest-runner python-typing-extensions))
+ (list python-pytest python-pytest-runner))
(home-page "https://github.com/PyCQA/astroid")
- (synopsis "Common base representation of python source code for pylint and
- other projects")
+ (synopsis "Python source code base representation")
(description "@code{python-astroid} provides a common base representation
- of python source code for projects such as pychecker, pyreverse, pylint, etc.
-
- It provides a compatible representation which comes from the _ast module. It
- rebuilds the tree generated by the builtin _ast module by recursively walking
- down the AST and building an extended ast. The new node classes have
- additional methods and attributes for different usages. They include some
- support for static inference and local name scopes. Furthermore, astroid
- builds partial trees by inspecting living objects.")
+of Python source code for projects such as pychecker, pyreverse, pylint, etc.
+It provides a compatible representation which comes from the _ast module. It
+rebuilds the tree generated by the builtin _ast module by recursively walking
+down the AST and building an extended ast. The new node classes have
+additional methods and attributes for different usages. They include some
+support for static inference and local name scopes. Furthermore, astroid
+builds partial trees by inspecting living objects.")
(license license:lgpl2.1+)))
(define-public python-isbnlib