summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-07 15:29:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:25 -0400
commit9b6bad8c337d8045d9b7041d590eefbb67571482 (patch)
tree13863cf84b9e71b3bfd925c9a9175db06345754c /gnu
parentdc5cf89205182f7538858993cc603d56aa231035 (diff)
downloadguix-patches-9b6bad8c337d8045d9b7041d590eefbb67571482.tar
guix-patches-9b6bad8c337d8045d9b7041d590eefbb67571482.tar.gz
gnu: Add python-unicodedata2.
* gnu/packages/python-xyz.scm (python-unicodedata2): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e1076b7190..e4cb812c53 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14622,6 +14622,23 @@ numbers with uncertainties. It can also yield the derivatives of any
expression.")
(license license:bsd-3)))
+(define-public python-unicodedata2
+ (package
+ (name "python-unicodedata2")
+ (version "14.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "unicodedata2" version))
+ (sha256
+ (base32 "110nnvh02ssp92xbmswy39aa186jrmb7m41x4220wigl8c0dzxs1"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/fonttools/unicodedata2")
+ (synopsis "Python unicodedata backport")
+ (description "This package corresponds to the latest @code{unicodedata}
+standard Python module.")
+ (license license:asl2.0)))
+
(define-public python-asteval
(package
(name "python-asteval")