summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-23 00:28:29 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:20 -0400
commit952c8f805cd1f67ae192c0904e89ba8fe490d8ba (patch)
treec029d557af1f9b5372d2b98cd334c7ae3b9bdc0b /gnu
parentdc04cf5598cc17d9220996b65266cb45b175cf7c (diff)
downloadguix-patches-952c8f805cd1f67ae192c0904e89ba8fe490d8ba.tar
guix-patches-952c8f805cd1f67ae192c0904e89ba8fe490d8ba.tar.gz
gnu: Add python-asttokens.
* gnu/packages/python-xyz.scm (python-asttokens): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9ed49d5cc3..1d3c4ca3e1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9033,6 +9033,28 @@ callback signature using a prototype function.")
abstract syntax tree (AST) nodes without side effects.")
(license license:expat)))
+(define-public python-asttokens
+ (package
+ (name "python-asttokens")
+ (version "2.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "asttokens" version))
+ (sha256
+ (base32 "1mglbkikxvnhrk3inbx0v1qzxwd38qjr6l35sn098yicy0ac2m4s"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-six))
+ (native-inputs (list python-astroid python-pytest python-setuptools-scm))
+ (home-page "https://github.com/gristlabs/asttokens")
+ (synopsis "Python library to annotate abstract syntax trees")
+ (description "The @code{asttokens} module annotates Python abstract syntax
+trees (ASTs) with the positions of tokens and text in the source code that
+generated them. It makes it possible for tools that work with logical AST
+nodes to find the particular text that resulted in those nodes, for example
+for automated refactoring or highlighting.")
+ (license license:asl2.0)))
+
(define-public python-ipython
(package
(name "python-ipython")