summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-01 20:40:53 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:25 -0400
commit51b36ab71f1e5051fff55ccc4fd1855a927985dd (patch)
treeefd9afb39e141ad0af88baeb62779bc70cef0d9d /gnu
parent9b6bad8c337d8045d9b7041d590eefbb67571482 (diff)
downloadguix-patches-51b36ab71f1e5051fff55ccc4fd1855a927985dd.tar
guix-patches-51b36ab71f1e5051fff55ccc4fd1855a927985dd.tar.gz
gnu: python-fonttools-with-test: Rename to python-fonttools-full.
* gnu/packages/python-xyz.scm (python-fonttools-with-test): Rename to... (python-fonttools-full): ... this. [native-inputs]: Move python-brotli, python-fs, python-scipy and python-zopfli to... [propagated-inputs]: ... here. Add python-lxml, python-lz4 and python-unicodedata2.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 12 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e4cb812c53..f8ef15cea1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11379,7 +11379,9 @@ from an XML-based format.")
(license license:expat)
(properties `((python2-variant . ,(delay python2-fonttools)))))))
-(define-public python-fonttools-with-tests
+;;; Rename 'python-fonttools' in next cycle, renaming the current
+;;; 'python-fonttools' to 'python-fonttools-minimal'.
+(define-public python-fonttools-full
(package/inherit python-fonttools
(arguments
(substitute-keyword-arguments (package-arguments python-fonttools)
@@ -11404,11 +11406,15 @@ from an XML-based format.")
" and not "))))))))))
(native-inputs
(modify-inputs (package-native-inputs python-fonttools)
- (append python-pytest ;FIXME: indentation is broken
- python-brotli
- python-fs
- python-scipy
- python-zopfli)))
+ (append python-pytest)))
+ (propagated-inputs
+ (list python-brotli
+ python-fs
+ python-lxml
+ python-lz4
+ python-scipy
+ python-unicodedata2
+ python-zopfli))
(properties (alist-delete 'hidden? (package-properties python-fonttools)))))
;; Fonttools 4.x dropped support for Python 2, so stick with 3.x here.