summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-07-15 17:43:18 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-07-17 01:55:58 +0200
commit9ba8cb43b928f2133dbea871f0e7d9aaf3afe785 (patch)
tree14f1f465e8381a150565a36804ee803e6fb932ee /gnu
parent4226c1f709336b93fc852d2736cfd36b419e513b (diff)
downloadguix-patches-9ba8cb43b928f2133dbea871f0e7d9aaf3afe785.tar
guix-patches-9ba8cb43b928f2133dbea871f0e7d9aaf3afe785.tar.gz
gnu: emacs-helm-projectile: Update to 1.0.0.
* gnu/packages/emacs-xyz.scm (emacs-helm-projectile): Update to 1.0.0. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm47
1 files changed, 21 insertions, 26 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index de8120532e..55afda50df 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8347,33 +8347,28 @@ for search-based navigation of buffers.")
as well as features for editing search results.")
(license license:gpl3+)))
-;; There hasn't been a tag or release since 2016, so we take the latest
-;; commit.
(define-public emacs-helm-projectile
- (let ((commit "5328b74dddcee8d1913803ca8167868831a07463")
- (version "0.14.0")
- (revision "1"))
- (package
- (name "emacs-helm-projectile")
- (version (git-version version revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/bbatsov/helm-projectile")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0a811cblrvc8llpv771b8dppgxs6bwjyvjy3qn2xns4nigvn93s0"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-helm" ,emacs-helm)
- ("emacs-projectile" ,emacs-projectile)))
- (home-page "https://github.com/bbatsov/helm-projectile")
- (synopsis "Helm integration for Projectile")
- (description
- "This Emacs library provides a Helm interface for Projectile.")
- (license license:gpl3+))))
+ (package
+ (name "emacs-helm-projectile")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bbatsov/helm-projectile")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05gpg90gg03yalmv9fw1y9k21i2l617iipvs0p9n80aln8nrzs8g"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)
+ ("emacs-projectile" ,emacs-projectile)))
+ (home-page "https://github.com/bbatsov/helm-projectile")
+ (synopsis "Helm integration for Projectile")
+ (description
+ "This Emacs library provides a Helm interface for Projectile.")
+ (license license:gpl3+)))
(define-public emacs-taskrunner
(let ((commit "3afd4a546d42339543d3d4e51b175fc3e82b3358")