summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-05-24 20:32:43 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-07 09:41:21 -0400
commite174191029529d19e7a8a12d749ec6aa2ae9ba3e (patch)
tree1521f3c253cbd41156203e715170792b585600e5 /gnu
parent7b8e9af56cb0a54842ac01716bd170dc30e91221 (diff)
downloadguix-patches-e174191029529d19e7a8a12d749ec6aa2ae9ba3e.tar
guix-patches-e174191029529d19e7a8a12d749ec6aa2ae9ba3e.tar.gz
gnu: Add go-github-com-riobard-go-bloom.
* gnu/packages/golang.scm (go-github-com-riobard-go-bloom): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cf59096c95..2acde4adb4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -74,6 +74,30 @@
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public go-github-com-riobard-go-bloom
+ (let ((commit "cdc8013cb5b3eb0efebec85f0e904efccac42df9")
+ (revision "0"))
+ (package
+ (name "go-github-com-riobard-go-bloom")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/riobard/go-bloom")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10a8ixh6zw52df2imxrzgxi82zc1j5hqnv5smjp818qwdn1a1rhj"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/riobard/go-bloom"))
+ (home-page "https://github.com/riobard/go-bloom")
+ (synopsis "Bloom filter in Go")
+ (description "Go-Bloom implements bloom filter using double hashing.")
+ (license license:asl2.0))))
+
(define-public go-github-com-aead-chacha20
(let ((commit "8b13a72661dae6e9e5dea04f344f0dc95ea29547")
(revision "0"))