summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-14 00:31:21 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-14 00:37:46 +0200
commita0244ef0008dd3c45ede84d5692c4be4327b60d0 (patch)
tree56c60ad465ee66f08e6650b0076c2a5369e61027 /gnu
parenta5a79dd0b88c0d9da09be7823c6158fa80ac5acd (diff)
downloadguix-patches-a0244ef0008dd3c45ede84d5692c4be4327b60d0.tar
guix-patches-a0244ef0008dd3c45ede84d5692c4be4327b60d0.tar.gz
gnu: Add r-rgdal.
* gnu/packages/cran.scm (r-rgdal): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 732028601f..3c300a39a6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15420,3 +15420,32 @@ or bootstrapping of parameters and models, feature reduction (feature
extraction and variable selection) as well as conversion between indices of
effect size.")
(license license:gpl3)))
+
+(define-public r-rgdal
+ (package
+ (name "r-rgdal")
+ (version "1.4-4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rgdal" version))
+ (sha256
+ (base32
+ "1my56hdc9x40ynxx1qwqwqxjvjxybmm00w4xg5gi8zgj19pffci5"))))
+ (properties `((upstream-name . "rgdal")))
+ (build-system r-build-system)
+ (inputs
+ `(("gdal" ,gdal)
+ ("proj.4" ,proj.4)
+ ("zlib" ,zlib)))
+ (propagated-inputs
+ `(("r-sp" ,r-sp)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://rgdal.r-forge.r-project.org")
+ (synopsis "Bindings for the Geospatial Data Abstraction Library")
+ (description
+ "This package provides bindings to the Geospatial Data Abstraction
+Library (GDAL) and access to projection/transformation operations from the
+PROJ.4 library.")
+ (license license:gpl2+)))