summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPjotr Prins <pjotr.public12@thebird.nl>2015-09-16 07:56:44 +0200
committerDavid Thompson <dthompson2@worcester.edu>2015-09-16 08:41:46 -0400
commitf9ae2c068dc5228f4f5072bcfbb214cfb8373069 (patch)
treeecf79f5718d57714e9242cb6d87b66208c15e408 /gnu
parent8ea6b30fea9637c5568c310d384bc13bc225648b (diff)
downloadguix-patches-f9ae2c068dc5228f4f5072bcfbb214cfb8373069.tar
guix-patches-f9ae2c068dc5228f4f5072bcfbb214cfb8373069.tar.gz
gnu: Add ruby-log4r.
* gnu/packages/ruby.scm (ruby-log4r): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7dc46b6caa..e61332f6aa 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -421,6 +421,30 @@ Java Native Interface.")
(home-page "http://www.artonx.org/collabo/backyard/?RubyJavaBridge")
(license license:lgpl2.1+)))
+(define-public ruby-log4r
+ (package
+ (name "ruby-log4r")
+ (version "1.1.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "log4r" version))
+ (sha256
+ (base32
+ "0ri90q0frfmigkirqv5ihyrj59xm8pq5zcmf156cbdv4r4l2jicv"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; no Rakefile in gem
+ (synopsis "Flexible logging library for Ruby")
+ (description "Comprehensive and flexible logging library written
+in Ruby for use in Ruby programs. It features a hierarchical logging
+system of any number of levels, custom level names, logger
+inheritance, multiple output destinations per log event, execution
+tracing, custom formatting, thread safteyness, XML and YAML
+configuration, and more.")
+ (home-page "http://log4r.rubyforge.org/")
+ (license license:bsd-3)))
+
(define-public ruby-atoulme-antwrap
(package
(name "ruby-atoulme-antwrap")