summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-09-14 22:16:53 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-09-16 22:53:36 +0200
commitde34aface7e0c83b02c3def1ec55630e29bed6b7 (patch)
treea5de367b1c2101f869479e5c76625a804f5161e1 /gnu
parentc7c7a93621ad38e8302ccf3f52e182b65ef3715d (diff)
downloadguix-patches-de34aface7e0c83b02c3def1ec55630e29bed6b7.tar
guix-patches-de34aface7e0c83b02c3def1ec55630e29bed6b7.tar.gz
gnu: Add python-webob.
* gnu/packages/python.scm (python-webob, python2-webob): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c58d7f3fc1..408064d9be 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4853,3 +4853,30 @@ fractional seconds) of a clock which never goes backwards.")
(define-public python2-monotonic
(package-with-python2 python-monotonic))
+
+(define-public python-webob
+ (package
+ (name "python-webob")
+ (version "1.5.0b0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/W/WebOb/WebOb-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "140b3iczclk1j0405rvw5gxshqfkhcc8254fj520z3m23cwbql4a"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-nose" ,python-nose)
+ ("python-setuptools" ,python-setuptools)))
+ (home-page "http://webob.org/")
+ (synopsis "WSGI request and response object")
+ (description
+ "WebOb provides wrappers around the WSGI request environment, and an
+object to help create WSGI responses.")
+ (license license:expat)))
+
+(define-public python2-webob
+ (package-with-python2 python-webob))