summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-09-09 00:44:14 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-09-14 00:14:55 +0200
commitb85c85becd36aa3abbd80dbb5b22705f10e5e57a (patch)
tree97709cdd121cd1a0d205de5e3670ca06ae9ca36a /gnu
parent8c692a52586937a58627ae609f08aaabb102b64f (diff)
downloadguix-patches-b85c85becd36aa3abbd80dbb5b22705f10e5e57a.tar
guix-patches-b85c85becd36aa3abbd80dbb5b22705f10e5e57a.tar.gz
gnu: Add python-iso8601.
* gnu/packages/python.scm (python-iso8601, python2-iso8601): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 04c842bc83..85ab88c709 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4799,3 +4799,30 @@ and MAC network addresses.")
(define-public python2-wrapt
(package-with-python2 python-wrapt))
+
+(define-public python-iso8601
+ (package
+ (name "python-iso8601")
+ (version "0.1.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/i/iso8601/iso8601-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1qf01afxh7j4gja71vxv345if8avg6nnm0ry0zsk6j3030xgy4p7"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "https://bitbucket.org/micktwomey/pyiso8601")
+ (synopsis "Module to parse ISO 8601 dates")
+ (description
+ "This module parses the most common forms of ISO 8601 date strings (e.g.
+@code{2007-01-14T20:34:22+00:00}) into @code{datetime} objects.")
+ (license license:expat)))
+
+(define-public python2-iso8601
+ (package-with-python2 python-iso8601))