summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-23 12:47:16 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-12 16:08:18 +0200
commitb74270eedb036d747aa65a52d45b6095d30becf2 (patch)
treeff2af43a5d9d1466c159815ed73d1ab2e0303a94 /gnu
parent6784f2e3fe744c7b67130f9136ec769e7b05f59f (diff)
downloadguix-patches-b74270eedb036d747aa65a52d45b6095d30becf2.tar
guix-patches-b74270eedb036d747aa65a52d45b6095d30becf2.tar.gz
gnu: Add python-pathpy.
* gnu/packages/python.scm (python-pathpy, python2-pathpy): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 307b888819..cf09bf4f1a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3825,6 +3825,34 @@ them as the version argument or in a SCM managed file.")
(define-public python2-setuptools-scm
(package-with-python2 python-setuptools-scm))
+(define-public python-pathpy
+ (package
+ (name "python-pathpy")
+ (version "8.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/p/"
+ "path.py/path.py-" version ".tar.gz"))
+ (sha256
+ (base32 "1p8s1l2vfkqhqxdhqlj0g1jjw4f1as2frr35sjcpjjpd5a89y41f"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-appdirs" ,python-appdirs)))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "http://github.com/jaraco/path.py")
+ (synopsis "Python module wrapper for built-in os.path")
+ (description
+ "@code{path.py} implements path objects as first-class entities, allowing
+common operations on files to be invoked on those path objects directly.")
+ (license license:expat)))
+
+(define-public python2-pathpy
+ (package-with-python2 python-pathpy))
+
(define-public python-ipython
(package
(name "python-ipython")