summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-09-08 00:22:49 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-09-13 23:21:54 +0200
commit6e5e39f4063b30fcea6d5a9af6769236d8a57cd3 (patch)
tree1f249766f0ff2812d0b4df8c0b767b4f72f813d7 /gnu
parent59ef20304b1b3b05fb4262e9e94b605d0b8f6e0d (diff)
downloadguix-patches-6e5e39f4063b30fcea6d5a9af6769236d8a57cd3.tar
guix-patches-6e5e39f4063b30fcea6d5a9af6769236d8a57cd3.tar.gz
gnu: Add python-netaddr.
* gnu/packages/python.scm (python-netaddr, python2-netaddr): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index feddd1a46a..f85c788f43 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4739,3 +4739,31 @@ reading and writing MessagePack data.")
(define-public python2-msgpack
(package-with-python2 python-msgpack))
+
+(define-public python-netaddr
+ (package
+ (name "python-netaddr")
+ (version "0.7.18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/n/netaddr/netaddr-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "06dxjlbcicq7q3vqy8agq11ra01kvvd47j4mk6dmghjsyzyckxd1"))))
+ (build-system python-build-system)
+ (arguments `(#:tests? #f)) ;; No tests.
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "https://github.com/drkjam/netaddr/")
+ (synopsis "Pythonic manipulation of network addresses")
+ (description
+ "A Python library for representing and manipulating IPv4, IPv6, CIDR, EUI
+and MAC network addresses.")
+ (license bsd-3)))
+
+(define-public python2-netaddr
+ (package-with-python2 python-netaddr))