summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVicente Vera Parra <vicentemvp@gmail.com>2015-09-15 14:12:32 -0300
committerRicardo Wurmus <rekado@elephly.net>2015-09-15 22:33:57 +0200
commit6af481343001c552f1c12f1e3128159685abef07 (patch)
treeaf7ef81f8c1a45da2cd00d4b8a9b195ad757bb61 /gnu
parented6094fc77267b14510e6fb589fca663e7e1ce04 (diff)
downloadguix-patches-6af481343001c552f1c12f1e3128159685abef07.tar
guix-patches-6af481343001c552f1c12f1e3128159685abef07.tar.gz
gnu: Add r-lazyeval.
* gnu/packages/statistics.scm (r-lazyeval): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 1c3d696028..6bd8e767ec 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -520,3 +520,22 @@ the pre and post conditions that your code should satisfy, while also
producing friendly error messages so that your users know what they've done
wrong.")
(license license:gpl3+)))
+
+(define-public r-lazyeval
+ (package
+ (name "r-lazyeval")
+ (version "0.1.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cran/src/contrib/lazyeval_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "02qfpn2fmy78vx4jxr7g7rhqzcm1kcivfwai7lbh0vvpawia0qwh"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/hadley/lazyeval")
+ (synopsis "Lazy (non-standard) evaluation in R")
+ (description
+ "This package provides the tools necessary to do non-standard
+evaluation (NSE) in R.")
+ (license license:gpl3+)))