summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-18 00:11:32 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:52 -0400
commit634a798f51c7c31d882b7888e49697aa0e8f32e4 (patch)
tree7f600b99706ba105058f9e6ee40aaf67244f7d1f /gnu
parentb4c4c2f82e91736bfc623df2b3f61335ec702231 (diff)
downloadguix-patches-634a798f51c7c31d882b7888e49697aa0e8f32e4.tar
guix-patches-634a798f51c7c31d882b7888e49697aa0e8f32e4.tar.gz
gnu: python-uvicorn: Update to 0.17.6.
* gnu/packages/python-web.scm (python-uvicorn): Update to 0.17.6. [phases]{check}: Delete extraneous add-installed-pythonpath and inputs/outputs arguments. Add the '-o' 'asyncio_mode=auto' option to pytest invocation, and skip two tests. [native-inputs]: Add python-httpx-bootstrap and python-pytest-asyncio. [propagated-inputs]: Add python-asgiref and python-dotenv.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm29
1 files changed, 21 insertions, 8 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 3e024b4fae..41de186b6f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5014,7 +5014,7 @@ and fairly speedy.")
(define-public python-uvicorn
(package
(name "python-uvicorn")
- (version "0.13.2")
+ (version "0.17.6")
(source
(origin
;; PyPI tarball has no tests.
@@ -5024,20 +5024,33 @@ and fairly speedy.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "04zgmp9z46k72ay6cz7plga6d3w3a6x41anabm7ramp7jdqf6na9"))))
+ (base32 "0npwls02nhna2lyw2nksxij16l9agf12c9f42pvxb5yrpi9l16c8"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "-o" "asyncio_mode=auto"
+ "-k"
+ (string-append
+ ;; These error or fail due to networking.
+ "not test_keepalive "
+ "and not test_bind_unix_socket_works_with_"
+ "reload_or_workers "))))))))
(native-inputs
- (list python-pytest python-pytest-mock python-requests
- python-trustme python-wsproto))
+ (list python-httpx-bootstrap
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-mock
+ python-requests
+ python-trustme
+ python-wsproto))
(propagated-inputs
- (list python-click
+ (list python-asgiref
+ python-click
+ python-dotenv
python-h11
python-httptools
python-pyyaml