summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-18 00:21:31 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:52 -0400
commit1f5f4cc1a2076ef40121f9e6c858e7c3081c7ef4 (patch)
tree613f7248c034d8508b84943658121779e938e7a0 /gnu
parent634a798f51c7c31d882b7888e49697aa0e8f32e4 (diff)
downloadguix-patches-1f5f4cc1a2076ef40121f9e6c858e7c3081c7ef4.tar
guix-patches-1f5f4cc1a2076ef40121f9e6c858e7c3081c7ef4.tar.gz
gnu: Add python-socksio.
* gnu/packages/python-web.scm (python-socksio): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 41de186b6f..0e837c8180 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6336,6 +6336,27 @@ your code non-blocking and speedy.")
functionality.")
(license license:asl2.0)))
+(define-public python-socksio
+ (package
+ (name "python-socksio")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "socksio" version))
+ (sha256
+ (base32 "1b64j45w35jzhjhnq44bnyad9ydh1iyyd7a6j2c8phxmllyyp2zq"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/sethmlarson/socksio")
+ (synopsis "Sans-I/O implementation of SOCKS4, SOCKS4A, and SOCKS5.")
+ (description "The @code{socksio} Python module is a client-side sans-I/O
+SOCKS proxy implementation. It supports SOCKS4, SOCKS4A, and SOCKS5.
+@code{socksio} is a sans-I/O library similar to @code{h11} or @code{h2}; this
+means the library itself does not handle the actual sending of the bytes
+through the network, it only deals with the implementation details of the
+SOCKS protocols. It can be paired with any I/O library.")
+ (license license:expat)))
+
(define-public python-azure-nspkg
(package
(name "python-azure-nspkg")