summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-21 14:34:35 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-21 14:34:35 +0000
commitf65917f6073b7af9b9249bf225a4ca1ef7f5598b (patch)
tree9760455c8562abf655936d103bf292d31de916ee /gnu
parent4885f40b80cec9c61bb006e21a64937045c6d5c4 (diff)
downloadguix-patches-f65917f6073b7af9b9249bf225a4ca1ef7f5598b.tar
guix-patches-f65917f6073b7af9b9249bf225a4ca1ef7f5598b.tar.gz
gnu: Add r-shaman.
* gnu/packages/bioinformatics.scm (r-shaman): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 13ed94c1c2..cd848b6e00 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7734,6 +7734,50 @@ of transcriptional heterogeneity among single cells.")
analyze genomic data resulting from various experiments.")
(license license:gpl2)))
+(define-public r-shaman
+ (let ((commit "d6944e8ac7bd1dbd5c6cec646eafc1d19d0ca96f")
+ (release "2.0")
+ (revision "2"))
+ (package
+ (name "r-shaman")
+ (version (git-version release revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tanaylab/shaman")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03sx138dzpfiq23j49z0m0s4j79855mrg64hpj9c83408wzphxi6"))
+ (snippet
+ ;; This file will be generated.
+ '(delete-file "inst/doc/shaman-package.R"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-data-table" ,r-data-table)
+ ("r-domc" ,r-domc)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gviz" ,r-gviz)
+ ("r-misha" ,r-misha)
+ ("r-plyr" ,r-plyr)
+ ("r-rann" ,r-rann)
+ ("r-rcpp" ,r-rcpp)
+ ("r-reshape2" ,r-reshape2)
+ ;; For vignettes
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/tanaylab/shaman")
+ (synopsis "Sampling HiC contact matrices for a-parametric normalization")
+ (description "The Shaman package implements functions for
+resampling Hi-C matrices in order to generate expected contact
+distributions given constraints on marginal coverage and
+contact-distance probability distributions. The package also provides
+support for visualizing normalized matrices and statistical analysis
+of contact distributions around selected landmarks.")
+ ;; Any version of the GPL
+ (license license:gpl3+))))
+
(define-public r-centipede
(package
(name "r-centipede")