summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-21 14:49:01 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-21 14:49:01 +0000
commita8bac123f0f556b5911e34ccfac733a78178643e (patch)
tree9a90b65dce93a6cfef674fb07d77774489a27c52 /gnu
parentf65917f6073b7af9b9249bf225a4ca1ef7f5598b (diff)
downloadguix-patches-a8bac123f0f556b5911e34ccfac733a78178643e.tar
guix-patches-a8bac123f0f556b5911e34ccfac733a78178643e.tar.gz
gnu: Add gdc-client.
* gnu/packages/bioinformatics.scm (gdc-client): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cd848b6e00..395e8ce509 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7841,6 +7841,46 @@ includes software to
")
(license license:cc0))))
+(define-public gdc-client
+ (package
+ (name "gdc-client")
+ (version "1.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/NCI-GDC/gdc-client.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cagawlzjwj3wam10lv64xgbfx4zcnzxi5sjpsdhq7rn4z24mzc2"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "requirements.txt"
+ (("==") ">=")))))))
+ (inputs
+ `(("python-cryptography" ,python-cryptography)
+ ("python-intervaltree" ,python-intervaltree)
+ ("python-jsonschema" ,python-jsonschema)
+ ("python-lxml" ,python-lxml)
+ ("python-ndg-httpsclient" ,python-ndg-httpsclient)
+ ("python-progressbar2" ,python-progressbar2)
+ ("python-pyasn1" ,python-pyasn1)
+ ("python-pyopenssl" ,python-pyopenssl)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-requests" ,python-requests)
+ ("python-termcolor" ,python-termcolor)))
+ (home-page "https://gdc.nci.nih.gov/access-data/gdc-data-transfer-tool")
+ (synopsis "GDC data transfer tool")
+ (description "The gdc-client provides several convenience functions over
+the GDC API which provides general download/upload via HTTPS.")
+ (license license:asl2.0)))
+
(define-public vsearch
(package
(name "vsearch")