summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-19 00:27:10 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 16:04:58 +0200
commit9fe4e45be705f98d89e1e49e6ca0c444a9aca00e (patch)
tree23b1a46999f6147d1c9e183470dbf13fbf4f2a2d /gnu
parentc1947a8c7df950d19d10df44e683b8860b14b321 (diff)
downloadguix-patches-9fe4e45be705f98d89e1e49e6ca0c444a9aca00e.tar
guix-patches-9fe4e45be705f98d89e1e49e6ca0c444a9aca00e.tar.gz
gnu: sharutils: Prepare for GCC 10.
* gnu/packages/compression.scm (sharutils)[source](snippet): Add substitution to avoid duplicate header definitions. [arguments]: Remove trailing #t.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 3dbe517f93..8a077c484b 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016, 2019, 2020 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2016, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
@@ -672,6 +672,7 @@ decompressors when faced with corrupted input.")
(modules '((guix build utils)))
(snippet
'(begin
+ ;; Adjust for newer libc versions.
(substitute* (find-files "lib" "\\.c$")
(("#if defined _IO_ftrylockfile")
"#if defined _IO_EOF_SEEN"))
@@ -681,7 +682,13 @@ decompressors when faced with corrupted input.")
"# define _IO_IN_BACKUP 0x100\n"
"#endif\n\n"
"/* BSD stdio derived implementations")))
- #t))))
+ ;; ... and for newer GCC with -fno-common.
+ (substitute* '("src/shar-opts.h"
+ "src/unshar-opts.h"
+ "src/uudecode-opts.h"
+ "src/uuencode-opts.h")
+ (("char const \\* const program_name" all)
+ (string-append "extern " all)))))))
(build-system gnu-build-system)
(inputs
`(("which" ,which)))
@@ -693,8 +700,7 @@ decompressors when faced with corrupted input.")
;; in fact test data
(lambda _
(substitute* "tests/shar-1.ok"
- (((which "sh")) "/bin/sh"))
- #t)))))
+ (((which "sh")) "/bin/sh")))))))
(home-page "https://www.gnu.org/software/sharutils/")
(synopsis "Archives in shell scripts, uuencode/uudecode")
(description