summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-10-05 22:18:09 +0200
committerLudovic Courtès <ludo@gnu.org>2014-10-05 22:24:33 +0200
commit8fa9ff20a80882868a28a6415c068e5376485b17 (patch)
tree740af70e02867b7f663fb46887dfdb1241c4025b /gnu
parent22e47b640e45b283d0885f86e5f1c39c8953671d (diff)
downloadguix-patches-8fa9ff20a80882868a28a6415c068e5376485b17.tar
guix-patches-8fa9ff20a80882868a28a6415c068e5376485b17.tar.gz
gnu: dbus: Create $out/etc/dbus-1/{system,session}.d to placate 'dbus-launch'.
* gnu/packages/glib.scm (dbus)[arguments]: Add 'post-install' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index a414a9d9de..662f511762 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -73,7 +73,17 @@
;; config.
;; "--sysconfdir=/etc"
- "--with-session-socket-dir=/tmp")))
+ "--with-session-socket-dir=/tmp")
+ #:phases (alist-cons-after
+ 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; 'dbus-launch' bails out if the 'session.d' directory
+ ;; below is missing, so create it along with its companion.
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir (string-append out "/etc/dbus-1/session.d"))
+ (mkdir (string-append out "/etc/dbus-1/system.d"))
+ #t))
+ %standard-phases)))
(inputs
`(("expat" ,expat)
("pkg-config" ,pkg-config)