summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-21 14:25:44 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-21 14:25:44 +0000
commit4885f40b80cec9c61bb006e21a64937045c6d5c4 (patch)
tree9b7fe721143f8658ef8092e7afa01f5830207ac2 /gnu
parent42c9b75b25fe13cca95c22e38bc60e1b28380c0a (diff)
downloadguix-patches-4885f40b80cec9c61bb006e21a64937045c6d5c4.tar
guix-patches-4885f40b80cec9c61bb006e21a64937045c6d5c4.tar.gz
gnu: Add r-misha.
* gnu/packages/bioinformatics.scm (r-misha): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0059ed36ad..13ed94c1c2 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7698,6 +7698,42 @@ of transcriptional heterogeneity among single cells.")
;; See https://github.com/hms-dbmi/scde/issues/38
(license license:gpl2)))
+(define-public r-misha
+ (package
+ (name "r-misha")
+ (version "4.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tanaylab/misha")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bgivx3lzjh3173jsfrhb5kvhjsn53br0n4hmyx7i3dwy2cnnp2p"))
+ ;; Delete bundled executable.
+ (snippet
+ '(delete-file "exec/bigWigToWig"))))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'do-not-use-bundled-bigWigToWig
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "R/misha.R"
+ (("get\\(\".GLIBDIR\"\\), \"/exec/bigWigToWig")
+ (string-append "\""
+ (assoc-ref inputs "kentutils")
+ "/bin/bigWigToWig"))))))))
+ (inputs
+ `(("kentutils" ,kentutils)))
+ (home-page "https://github.com/tanaylab/misha")
+ (synopsis "Toolkit for analysis of genomic data")
+ (description "This package is intended to help users to efficiently
+analyze genomic data resulting from various experiments.")
+ (license license:gpl2)))
+
(define-public r-centipede
(package
(name "r-centipede")