summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-21 13:39:36 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-21 13:39:36 +0000
commit42c9b75b25fe13cca95c22e38bc60e1b28380c0a (patch)
treefac801790e6adca9f1daed712a4eb1f37838b33d /gnu
parent10664fcc8c557a33a6670db8fb2ecec8eaa68d0d (diff)
downloadguix-patches-42c9b75b25fe13cca95c22e38bc60e1b28380c0a.tar
guix-patches-42c9b75b25fe13cca95c22e38bc60e1b28380c0a.tar.gz
gnu: Add ciri-long.
* gnu/packages/bioinformatics.scm (ciri-long): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2593dc1f55..0059ed36ad 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1311,6 +1311,56 @@ relying on a complex dependency tree.")
(define-public python2-fastalite
(package-with-python2 python-fastalite))
+(define-public ciri-long
+ (package
+ (name "ciri-long")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bioinfo-biols/CIRI-long")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10k88i1fcqchrrjv82rmylwvbwqfba0n51palhig9hsg71xs0dbi"))
+ ;; Delete bundled binary
+ (snippet '(delete-file "libs/ccs"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("'argparse[^']*',") "") ; only for python2
+ (("==") ">="))))
+ (add-before 'build 'build-libssw
+ (lambda _
+ (with-directory-excursion "libs/striped_smith_waterman"
+ (invoke "make" "libssw.so")))))))
+ (inputs
+ `(("python-biopython" ,python-biopython)
+ ("python-bwapy" ,python-bwapy)
+ ("python-cython" ,python-cython)
+ ("python-levenshtein" ,python-levenshtein)
+ ("python-mappy" ,python-mappy)
+ ("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)
+ ("python-pysam" ,python-pysam)
+ ("python-pyspoa" ,python-pyspoa)
+ ("python-scikit-learn" ,python-scikit-learn)
+ ("python-scipy" ,python-scipy)))
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-setuptools" ,python-setuptools)))
+ (home-page "https://ciri-cookbook.readthedocs.io/")
+ (synopsis "Circular RNA identification for Nanopore sequencing")
+ (description "CIRI-long is a package for circular RNA identification using
+long-read sequencing data.")
+ (license license:expat)))
+
(define-public bpp-core
;; The last release was in 2014 and the recommended way to install from source
;; is to clone the git repository, so we do this.