summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-03-31 01:11:19 -0500
committerEric Bavier <bavier@member.fsf.org>2016-04-15 00:23:29 -0500
commit1555aee7d03fc9931eb870bdfb272a889f0cadc4 (patch)
tree1e0dcf45b3fcb9a895d8c96c1e8701b461fc3aea /gnu
parent508a85dfd6a0f10b460020535ee5d13e5d304089 (diff)
downloadguix-patches-1555aee7d03fc9931eb870bdfb272a889f0cadc4.tar
guix-patches-1555aee7d03fc9931eb870bdfb272a889f0cadc4.tar.gz
gnu: Add ttf2eot.
* gnu/packages/fontutils.scm (ttf2eot): New variable. * gnu/packages/patches/ttf2eot-cstddef.patch: New patch. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fontutils.scm37
-rw-r--r--gnu/packages/patches/ttf2eot-cstddef.patch12
2 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index a413e86ec6..dc18daaeb6 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -144,6 +144,43 @@ Converts WOFF fonts to OpenType fonts
(license (list license:mpl1.1 license:gpl2+ license:lgpl2.1+))
(home-page "https://people.mozilla.com/~jkew/woff/")))
+(define-public ttf2eot
+ (package
+ (name "ttf2eot")
+ (version "0.0.2-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://storage.googleapis.com/"
+ "google-code-archive-downloads/v2/"
+ "code.google.com/ttf2eot/"
+ "ttf2eot-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1f4dzzmhn0208dvbm3ia5ar6ls9apwc6ampy5blmfxkigi6z0g02"))
+ (patches (list (search-patch "ttf2eot-cstddef.patch")))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ;no configuration
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "ttf2eot" bin)))))))
+ (synopsis "Convert from TrueType to Embeddable Open Type")
+ (description
+ "This package contains a commandline wrapper around OpenTypeUtilities.cpp
+from Chromium, used to make EOT (Embeddable Open Type) files from
+TTF (TrueType/OpenType Font) files.")
+ ;; While the README states "License: Derived from WebKit, so BSD/LGPL
+ ;; 2/LGPL 2.1", the single derived source file includes only BSD in its
+ ;; license header, and the wrapper source contains no license header.
+ (license license:bsd-2)
+ (home-page "https://code.google.com/archive/p/ttf2eot/")))
+
(define-public fontconfig
(package
(name "fontconfig")
diff --git a/gnu/packages/patches/ttf2eot-cstddef.patch b/gnu/packages/patches/ttf2eot-cstddef.patch
new file mode 100644
index 0000000000..af76898e77
--- /dev/null
+++ b/gnu/packages/patches/ttf2eot-cstddef.patch
@@ -0,0 +1,12 @@
+From resolution of https://code.google.com/p/ttf2eot/issues/detail?id=26
+
+--- ttf2eot-0.0.2-2/OpenTypeUtilities.cpp 2009-04-30 04:18:46.000000000 -0500
++++ ttf2eot-0.0.2-2/OpenTypeUtilities.cpp 2016-03-31 01:06:39.109996011 -0500
+@@ -25,6 +25,7 @@
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
++#include <cstddef>
+ #include <string.h>
+ #include <vector>
+