summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-21 13:33:20 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-21 13:33:51 +0000
commit10664fcc8c557a33a6670db8fb2ecec8eaa68d0d (patch)
treeb9bbddb789e52e78e8b7163d524267048337c213 /gnu
parent579f31396dd8066c013cb3b6463e85dba5e84c52 (diff)
downloadguix-patches-10664fcc8c557a33a6670db8fb2ecec8eaa68d0d.tar
guix-patches-10664fcc8c557a33a6670db8fb2ecec8eaa68d0d.tar.gz
gnu: python-biopython: Update to 1.76.
* gnu/packages/bioinformatics.scm (python-biopython): Update to 1.76. (python-biopython-1.73): New variable. (instrain)[inputs]: Replace python-biopython with python-biopython-1.73.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5c4d5abdb4..2593dc1f55 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1245,14 +1245,14 @@ sequencing.")
(define-public python-biopython
(package
(name "python-biopython")
- (version "1.73")
+ (version "1.76")
(source (origin
(method url-fetch)
;; use PyPi rather than biopython.org to ease updating
(uri (pypi-uri "biopython" version))
(sha256
(base32
- "1q55jhf76z3k6is3psis0ckbki7df26x7dikpcc3vhk1vhkwribh"))))
+ "0wlch9xpa0fpgjzyxi6jsfca6iakaq9a05927xg8vqnmvaccnwrq"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1273,6 +1273,18 @@ dealing with alignments; code making it easy to split up parallelizable tasks
into separate processes; and more.")
(license (license:non-copyleft "http://www.biopython.org/DIST/LICENSE"))))
+(define-public python-biopython-1.73
+ (package
+ (inherit python-biopython)
+ (version "1.73")
+ (source (origin
+ (method url-fetch)
+ ;; use PyPi rather than biopython.org to ease updating
+ (uri (pypi-uri "biopython" version))
+ (sha256
+ (base32
+ "1q55jhf76z3k6is3psis0ckbki7df26x7dikpcc3vhk1vhkwribh"))))))
+
(define-public python2-biopython
(package-with-python2 python-biopython))
@@ -11730,7 +11742,7 @@ set.")
(("from job_utils")
"from .job_utils")))))))
(inputs
- `(("python-biopython" ,python-biopython)
+ `(("python-biopython" ,python-biopython-1.73)
("python-boto3" ,python-boto3)
("python-h5py" ,python-h5py)
("python-lmfit" ,python-lmfit)