summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-03-30 17:53:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-05 10:56:23 +0200
commitd3e1a94391a838332b0565d56762a58cf87ac6b1 (patch)
treede14e45599b6096db92eea0f5c39a6058d105336 /gnu
parent20303c0b1c75bc4770cdfa8b8c6b33fd6e77c168 (diff)
downloadguix-patches-d3e1a94391a838332b0565d56762a58cf87ac6b1.tar
guix-patches-d3e1a94391a838332b0565d56762a58cf87ac6b1.tar.gz
gnu: python2-pyyaml: Detach source from python-pyyaml.
* gnu/packages/python-xyz.scm (python2-pyyaml): Override source and version fields. (python-pyyaml)[properties]: Add python2-variant.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 60a13906d1..ff36c988c7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3925,10 +3925,21 @@ environments and back.")
complete YAML 1.1 parser, Unicode support, pickle support, capable extension
API, and sensible error messages. PyYAML supports standard YAML tags and
provides Python-specific tags that represent an arbitrary Python object.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-pyyaml))))))
(define-public python2-pyyaml
- (package-with-python2 python-pyyaml))
+ (let ((base (package-with-python2 (strip-python2-variant python-pyyaml))))
+ (package
+ (inherit base)
+ (version "5.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyYAML" version))
+ (sha256
+ (base32
+ "0pm440pmpvgv5rbbnm8hk4qga5a292kvlm1bh3x2nwr8pb5p8xv0")))))))
(define-public python-vine
(package