summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-11-18 19:12:41 -0600
committerEric Bavier <bavier@member.fsf.org>2015-11-19 03:13:20 -0600
commitc3c61a781c5e8d1b50f744b7f3640156762d5fee (patch)
tree9f7136fe5deca5dd49dbc201c996cd6a83e554eb /gnu
parent4eca62be493fc0f8447dc3b235412e517edf2b48 (diff)
downloadguix-patches-c3c61a781c5e8d1b50f744b7f3640156762d5fee.tar
guix-patches-c3c61a781c5e8d1b50f744b7f3640156762d5fee.tar.gz
gnu: ghc-unordered-containers: Enable tests.
* gnu/packages/haskell.scm (ghc-unordered-containers) [arguments]: Remove. [inputs]: Add ghc-chasingbottoms, ghc-test-framework, ghc-test-framework-hunit, and ghc-test-framework-quickcheck2.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index dc361eb172..137f6e9ee1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3051,12 +3051,14 @@ Partial and Infinite Values\"}.")
"06l1xv7vhpxly75saxdrbc6p2zlgz1az278arfkz4rgawfnphn3f"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-hunit" ,ghc-hunit)
- ("ghc-quickcheck" ,ghc-quickcheck)))
+ `(("ghc-chasingbottoms" ,ghc-chasingbottoms)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
;; these inputs are necessary to use this library
(propagated-inputs `(("ghc-hashable" ,ghc-hashable)))
- (arguments
- `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
(home-page
"https://github.com/tibbe/unordered-containers")
(synopsis