summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-11-19 18:08:03 -0600
committerEric Bavier <bavier@member.fsf.org>2015-11-20 11:58:40 -0600
commit9cf5245497b84ff5fd7fb10f9bab1fe17c202e5d (patch)
tree3e8455c7b0389de5f66261d71dce75454f5bc4f5 /gnu
parent32187d99bbb26f261e627e0d4a37e6baad344506 (diff)
downloadguix-patches-9cf5245497b84ff5fd7fb10f9bab1fe17c202e5d.tar
guix-patches-9cf5245497b84ff5fd7fb10f9bab1fe17c202e5d.tar.gz
gnu: slepc: Update to 3.6.2.
* gnu/packages/maths.scm (slepc): Update to 3.6.2. [arguments]: Append "/lib" to arpack configure flag. Use 'inputs' rather than '%build-inputs' in 'configure phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 144168726a..5af784c47f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -625,7 +625,7 @@ scientific applications modeled by partial differential equations.")
(define-public slepc
(package
(name "slepc")
- (version "3.6.0")
+ (version "3.6.2")
(source
(origin
(method url-fetch)
@@ -633,7 +633,7 @@ scientific applications modeled by partial differential equations.")
"filename=slepc-" version ".tar.gz"))
(sha256
(base32
- "1ij8w864spzk4cq2mmkssqyj0mbckkkvxm0wpw9gywy2jgbj07jr"))))
+ "1pv5iqz2kc8sj49zsabyz4arnfpana8mjrhq31vzgk16xldk3d1a"))))
(build-system gnu-build-system)
(native-inputs
`(("python" ,python-2)))
@@ -646,7 +646,7 @@ scientific applications modeled by partial differential equations.")
`(#:parallel-build? #f ;build is parallel by default
#:configure-flags
`(,(string-append "--with-arpack-dir="
- (assoc-ref %build-inputs "arpack")))
+ (assoc-ref %build-inputs "arpack") "/lib"))
#:phases
(modify-phases %standard-phases
(replace
@@ -660,7 +660,7 @@ scientific applications modeled by partial differential equations.")
(format #t "build directory: ~s~%" (getcwd))
(format #t "configure flags: ~s~%" flags)
(setenv "SLEPC_DIR" (getcwd))
- (setenv "PETSC_DIR" (assoc-ref %build-inputs "petsc"))
+ (setenv "PETSC_DIR" (assoc-ref inputs "petsc"))
(zero? (apply system* "./configure" flags)))))
(add-after
'install 'delete-doc