summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-24 02:31:30 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-28 15:52:30 +0200
commit4696368108c2e1500a8f1d8a0d75b5f0aef1c37a (patch)
tree8dd6484e7ee88456f1970809fe1b996d27d8b998 /gnu
parentfc8778e2934e623b4cfae253942a721cea42a43b (diff)
downloadguix-patches-4696368108c2e1500a8f1d8a0d75b5f0aef1c37a.tar
guix-patches-4696368108c2e1500a8f1d8a0d75b5f0aef1c37a.tar.gz
gnu: python-fonttools: Update to 3.28.0.
* gnu/packages/python.scm (python-fonttools): Update to 3.28.0. [arguments]: Remove. [native-inputs]: Add PYTHON-PYTEST and PYTHON-PYTEST-RUNNER.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm20
1 files changed, 5 insertions, 15 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 60a41ea0cd..7e46a76109 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5894,28 +5894,18 @@ add functionality and customization to your projects with their own plugins.")
(define-public python-fonttools
(package
(name "python-fonttools")
- (version "3.15.1")
+ (version "3.28.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "fonttools" version ".zip"))
(sha256
(base32
- "1hhj97izwliy0vybmza72d90l5d4mcn50y8akq7kyccfl82vdx4d"))))
+ "0vsvjhidpb5kywpjgz1j3fywzkddxkb0afqai18qa3h6lqjyxwpb"))))
(build-system python-build-system)
- (arguments
- '(#:test-target "check"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-setuppy
- ;; Remove the undocumented "extra_path" argument, which adds an
- ;; intervening directories between site-packages and the package
- ;; directory.
- (lambda _
- (substitute* "setup.py"
- (("^[ \t]*extra_path *= *'FontTools',") ""))
- #t)))))
(native-inputs
- `(("unzip" ,unzip)))
+ `(("unzip" ,unzip)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
(home-page "https://github.com/behdad/fonttools")
(synopsis "Tools to manipulate font files")
(description