summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-23 23:41:37 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-28 15:52:29 +0200
commit1166b9c795e3762ece2623143ae2fe0984b4a158 (patch)
treefd5d0a55c55dc2f3048b288215be3f633fea963b /gnu
parent9f585a528eb7dc9ae5e1c1d901f84189ef8063e9 (diff)
downloadguix-patches-1166b9c795e3762ece2623143ae2fe0984b4a158.tar
guix-patches-1166b9c795e3762ece2623143ae2fe0984b4a158.tar.gz
gnu: Add python-invoke.
* gnu/packages/python.scm (python-invoke, python2-invoke): New public variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 130769800f..60a41ea0cd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10767,6 +10767,32 @@ projects.")
(define-public python2-incremental
(package-with-python2 python-incremental))
+(define-public python-invoke
+ (package
+ (name "python-invoke")
+ (home-page "http://www.pyinvoke.org/")
+ (version "1.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "invoke" version))
+ (sha256
+ (base32
+ "0aiy1xvk1f91246zxd1zqrm679vdvd10h843a2na41cqr3cflpi6"))))
+ (build-system python-build-system)
+ (arguments
+ ;; XXX: Requires many dependencies that are not yet in Guix.
+ `(#:tests? #f))
+ (synopsis "Pythonic task execution")
+ (description
+ "Invoke is a Python task execution tool and library, drawing inspiration
+from various sources to arrive at a powerful and clean feature set. It is
+evolved from the Fabric project, but focuses on local and abstract concerns
+instead of servers and network commands.")
+ (license license:bsd-3)))
+
+(define-public python2-invoke
+ (package-with-python2 python-invoke))
+
(define-public python-automat
(package
(name "python-automat")