summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-06-16 22:07:49 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-06-21 21:29:17 +1000
commit0846620803685bd35675ebcb4bfcff806c21c990 (patch)
tree1fd517316b0f4e3e6592fb22f746bda72a22ef2e /gnu
parentde682e6f0f9eda05c546124c0da6edae38df3701 (diff)
downloadguix-patches-0846620803685bd35675ebcb4bfcff806c21c990.tar
guix-patches-0846620803685bd35675ebcb4bfcff806c21c990.tar.gz
gnu: Add r-mgcv.
* gnu/packages/statistics.scm (r-mgcv): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index e5911d7a4a..c84845dd29 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -378,6 +378,27 @@ and Francois (2011, JSS), and the book by Eddelbuettel (2013, Springer); see
'citation(\"Rcpp\")' for details on these last two.")
(license license:gpl2+)))
+(define-public r-mgcv
+ (package
+ (name "r-mgcv")
+ (version "1.8-12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mgcv" version))
+ (sha256
+ (base32
+ "1khzy36nn6xbnzqfc2953ng0sv8w91mns1ymhibaqn1150x1qid0"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/mgcv")
+ (synopsis "Mixed generalised additive model computation")
+ (description
+ "GAMs, GAMMs and other generalized ridge regression with multiple smoothing
+parameter estimation by GCV, REML or UBRE/AIC. The library includes a
+@code{gam()} function, a wide variety of smoothers, JAGS support and
+distributions beyond the exponential family.")
+ (license license:gpl2+)))
+
(define-public r-permute
(package
(name "r-permute")