summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-03-29 10:37:47 +0200
committerLudovic Courtès <ludo@gnu.org>2021-03-30 22:48:46 +0200
commitf27a7c18b6eea7e476cf76c701db1f0cd2fd50c8 (patch)
tree733fca5208d6141f3cec0c9470b4b4147a2dc773 /gnu
parent9b8632fceca9b0b95d76a9fbf5b8274cdeef98cf (diff)
downloadguix-patches-f27a7c18b6eea7e476cf76c701db1f0cd2fd50c8.tar
guix-patches-f27a7c18b6eea7e476cf76c701db1f0cd2fd50c8.tar.gz
gnu: gnome-shell: Adjust to new #:disallowed-references convention.
* gnu/packages/gnome.scm (gnome-shell)[arguments]: List gexp-inputs in #:disallowed-references.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 624fdf3837..f296fa37d4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2014, 2016, 2020 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
@@ -8472,9 +8472,10 @@ properties, screen resolution, and other GNOME parameters.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:disallowed-references ((,glib "bin")
- ,inkscape ,libxslt
- ,ruby-sass)
+ #:disallowed-references ,(list (gexp-input glib "bin")
+ (gexp-input inkscape)
+ (gexp-input libxslt)
+ (gexp-input ruby-sass))
#:configure-flags
(list "-Dsystemd=false"
;; Otherwise, the RUNPATH will lack the final path component.