summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-01-16 22:10:26 +0800
committer宋文武 <iyzsong@gmail.com>2015-01-17 12:24:20 +0800
commit622c8f0af2caaa1c6698219a89de4aa6eac11b4f (patch)
treebdd2428f91c324c740926550fe0de3a16bb58919 /gnu
parentf1597358852d8e7144f1ec9f8e596833132bb688 (diff)
downloadguix-patches-622c8f0af2caaa1c6698219a89de4aa6eac11b4f.tar
guix-patches-622c8f0af2caaa1c6698219a89de4aa6eac11b4f.tar.gz
gnu: ffmpeg: Augment rpath of libraries.
* gnu/packages/video.scm (ffmpeg)[arguments]<phases>[add-lib-to-run-path]: Add $out/lib to the RUNPATH of libraries.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2febd12ff7..110d0995bb 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -184,10 +184,11 @@
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(lib (string-append out "/lib")))
- ;; Add LIB to the RUNPATH of all the executables.
+ ;; Add LIB to the RUNPATH of all the executables and libraries.
(with-directory-excursion out
(for-each (cut augment-rpath <> lib)
- (find-files "bin" ".*")))))
+ (append (find-files "bin" ".*")
+ (find-files "lib" "\\.so\\..*\\."))))))
%standard-phases))))
(home-page "http://www.ffmpeg.org/")
(synopsis "Audio and video framework")