summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPkill -9 <pkill9@runbox.com>2019-02-21 13:02:07 +0000
committerLudovic Courtès <ludo@gnu.org>2019-03-24 00:13:53 +0100
commit6f565d6c771b337ec43ef5ac2bb3670a37035bd9 (patch)
tree683448fcdca98eaefacdf3b8bb1600db6ee1c7e8 /gnu
parent920c896c1a3fdcdcd5a38bbb712b145dbbe53c94 (diff)
downloadguix-patches-6f565d6c771b337ec43ef5ac2bb3670a37035bd9.tar
guix-patches-6f565d6c771b337ec43ef5ac2bb3670a37035bd9.tar.gz
gnu: Add odamex.
* gnu/packages/games.scm (odamex): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e750d0657e..98438808ec 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5397,6 +5397,34 @@ Strife, Chex Quest, and fan-created games like Harmony, Hacx and Freedoom.")
"file://dumb/licence.txt"
"Dumb license, explicitly GPL compatible.")))))
+(define-public odamex
+ (package
+ (name "odamex")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/odamex/Odamex/" version "/"
+ "odamex-src-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1sh6lqj7vsdmnqz17hw0b6vy7xx6dp41k2sdw99ympsfa2xd1d2j"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; no tests.
+ (inputs
+ `(("sdl" ,sdl)
+ ("sdl-mixer" ,sdl-mixer)
+ ("zlib" ,zlib)
+ ("libpng" ,libpng)
+ ("alsa-lib" ,alsa-lib)))
+ (home-page "https://odamex.net/")
+ (synopsis "Multiplayer Doom port")
+ (description "Odamex is a modification of the Doom engine that
+allows players to easily join servers dedicated to playing Doom
+online.")
+ (license license:gpl2+)))
+
(define-public fortune-mod
(package
(name "fortune-mod")