summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-03-23 19:22:37 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-03-23 22:58:57 +0100
commit23c8a97a5b2766eb853a161c47cc86babf3b4322 (patch)
treee3d5c379b002d7672e0ea3347805791744bda739 /gnu
parent78b3748c1c5446f19e7a74ec424d61a7826fc843 (diff)
downloadguix-patches-23c8a97a5b2766eb853a161c47cc86babf3b4322.tar
guix-patches-23c8a97a5b2766eb853a161c47cc86babf3b4322.tar.gz
gnu: ocaml-alcotest: Update to 0.8.5.
* gnu/packages/ocaml.scm (ocaml-alcotest): Update to 0.8.5.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 801611beb1..a6889c642e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1724,28 +1724,26 @@ immutability.")
(define-public ocaml-alcotest
(package
(name "ocaml-alcotest")
- (version "0.7.2")
+ (version "0.8.5")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mirage/alcotest/releases/"
"download/" version "/alcotest-" version ".tbz"))
(sha256
(base32
- "0g5lzk0gpfx4q8hyhr460gr4lab5wakfxsmhfwvb3yinxwzs95gc"))))
- (build-system ocaml-build-system)
+ "0szwjxvaahgynsx0apj81jxj3ki6yz4is9mh2wkcbx66qy7n6fvb"))))
+ (build-system dune-build-system)
(arguments
- `(#:tests? #f
- #:build-flags (list "build")
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
+ `(#:package "alcotest"
+ #:test-target "."))
(native-inputs
- `(("ocamlbuild" ,ocamlbuild)
- ("opam" ,opam)
- ("topkg" ,ocaml-topkg)))
+ `(("ocamlbuild" ,ocamlbuild)))
(propagated-inputs
- `(("fmt" ,ocaml-fmt)
- ("astring" ,ocaml-astring)))
+ `(("ocaml-astring" ,ocaml-astring)
+ ("ocaml-cmdliner" ,ocaml-cmdliner)
+ ("ocaml-fmt" ,ocaml-fmt)
+ ("ocaml-result" ,ocaml-result)
+ ("ocaml-uuidm" ,ocaml-uuidm)))
(home-page "https://github.com/mirage/alcotest")
(synopsis "Lightweight OCaml test framework")
(description "Alcotest exposes simple interface to perform unit tests. It