summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-03-28 15:22:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-03-28 15:22:49 +0200
commit8e994ea51239c9b1664cb343be578ef7a052f886 (patch)
treee5bb2fbdbfee59a7530be6525dd3d4775fa65165 /gnu
parent738da660ff51e03b5ef63af9fa81eb50cb222928 (diff)
downloadguix-patches-8e994ea51239c9b1664cb343be578ef7a052f886.tar
guix-patches-8e994ea51239c9b1664cb343be578ef7a052f886.tar.gz
gnu: Add r-homologene.
* gnu/packages/cran.scm (r-homologene): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 23645faa8a..0ed601b4d3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2821,6 +2821,31 @@ distributions, and a variety of utility functions.")
;; Either version of the GPL.
(license (list license:gpl2 license:gpl3))))
+(define-public r-homologene
+ (package
+ (name "r-homologene")
+ (version "1.4.68.19.3.27")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "homologene" version))
+ (sha256
+ (base32 "0d7wxisk0vqk1n165v1i19bc02zv78h5r5d3jqai5y6nkmwn01sh"))))
+ (properties `((upstream-name . "homologene")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-dplyr r-magrittr r-purrr r-r-utils r-readr))
+ (home-page "https://github.com/oganm/homologene")
+ (synopsis "Quick access to homologene and gene annotation updates")
+ (description
+ "This package provides a wrapper for the homologene database by the
+National Center for Biotechnology Information (NCBI). It allows searching for
+gene homologs across species. The package also includes an updated version of
+the homologene database where gene identifiers and symbols are replaced with
+their latest (at the time of submission) version and functions to fetch latest
+annotation data to keep updated.")
+ (license license:expat)))
+
(define-public r-ggtern
(package
(name "r-ggtern")