summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2022-03-31 12:58:49 +0530
committerEfraim Flashner <efraim@flashner.co.il>2022-03-31 16:14:53 +0300
commit1ca9d9e1942b674cd2a4ce55ebfebc4485870366 (patch)
treeb33c73b3d2276c0d4b1d121981b050303be4acd1 /gnu
parent8524904e082464b7eb0c10037613b73da4d4df5e (diff)
downloadguix-patches-1ca9d9e1942b674cd2a4ce55ebfebc4485870366.tar
guix-patches-1ca9d9e1942b674cd2a4ce55ebfebc4485870366.tar.gz
gnu: Add wfmash.
* gnu/packages/bioinformatics.scm (wfmash): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9c7ef41cc1..7a7f2f722e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -16124,3 +16124,48 @@ workflows from concise descriptions in ccwl. It is implemented as an
@acronym{EDSL, Embedded Domain Specific Language} in the Scheme programming
language.")
(license license:gpl3+)))
+
+(define-public wfmash
+ (package
+ (name "wfmash")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ekg/wfmash/releases/download/v"
+ version "/wfmash-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "031cm1arpfckvihb28vlk69mirpnmlag81zcscfba1bac58wvr7c"))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ ;; Unbundle atomic-queue.
+ (delete-file-recursively "src/common/atomic_queue")
+ (substitute* "src/align/include/computeAlignments.hpp"
+ (("\"common/atomic_queue/atomic_queue.h\"")
+ "<atomic_queue/atomic_queue.h>"))
+ ;; Remove compiler optimizations.
+ (substitute* (find-files "." "CMakeLists\\.txt")
+ (("-mcx16 ") "")
+ (("-march=native ") ""))
+ ;; Allow building on architectures other than x86_64.
+ (substitute* "src/common/dset64.hpp"
+ (("!__x86_64__") "0"))))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ; no tests
+ (inputs
+ (list atomic-queue
+ gsl
+ htslib
+ jemalloc
+ zlib))
+ (synopsis "Base-accurate DNA sequence aligner")
+ (description "@code{wfmash} is a DNA sequence read mapper based on mash
+distances and the wavefront alignment algorithm. It is a fork of MashMap that
+implements base-level alignment via the wflign tiled wavefront global
+alignment algorithm. It completes MashMap with a high-performance alignment
+module capable of computing base-level alignments for very large sequences.")
+ (home-page "https://github.com/ekg/wfmash")
+ (license license:expat)))