summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-20 13:48:10 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-20 14:22:37 -0500
commit686805ca2b05a92d68a6a43667b6060284596614 (patch)
tree878e0516c6c6aee0904e92ba5084b74466568ea4 /gnu
parent1699b2d969806e7388ab5a00354b7938a7887757 (diff)
downloadguix-patches-686805ca2b05a92d68a6a43667b6060284596614.tar
guix-patches-686805ca2b05a92d68a6a43667b6060284596614.tar.gz
gnu: Add Perl JSON.
* gnu/packages/perl.scm (perl-json): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 742a123854..3c3c8173e4 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1874,6 +1874,27 @@ Perlish API and none of the bloat and rarely used features of IPC::Run.")
allowing data to be efficiently communicated between processes.")
(license (package-license perl))))
+(define-public perl-json
+ (package
+ (name "perl-json")
+ (version "2.90")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MA/MAKAMAKA/"
+ "JSON-" version ".tar.gz"))
+ (sha256
+ (base32
+ "127yppvr17qik9pkd1vy901hs4l13kg6rhp76jdgcyask35v7nsd"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-json-xs" ,perl-json-xs))) ;recommended
+ (home-page "http://search.cpan.org/dist/JSON")
+ (synopsis "JSON encoder/decoder for Perl")
+ (description "This module converts Perl data structures to JSON and vice
+versa using either JSON::XS or JSON::PP.")
+ (license (package-license perl))))
+
(define-public perl-json-xs
(package
(name "perl-json-xs")