summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-17 14:13:06 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-19 16:43:30 -0500
commit622d9adbd5e72a0789b5f435d432b4fbf12dcfb5 (patch)
tree7054ab519922e82b2c397542d0a88d8b4df300f4 /gnu
parent207d9126aa844876579d5bb4e7f00e21f42f333d (diff)
downloadguix-patches-622d9adbd5e72a0789b5f435d432b4fbf12dcfb5.tar
guix-patches-622d9adbd5e72a0789b5f435d432b4fbf12dcfb5.tar.gz
gnu: Add Carp-Assert-More.
* gnu/packages/perl.scm (perl-carp-assert-more): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 85bdea2f0d..7f147ac35f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -275,6 +275,29 @@ is captured while being passed through to the original file handles.")
library assert.h.")
(license (package-license perl))))
+(define-public perl-carp-assert-more
+ (package
+ (name "perl-carp-assert-more")
+ (version "1.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/P/PE/PETDANCE/"
+ "Carp-Assert-More-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0cq7qk4qbhqppm4raby5k24b5mx5qjgy1884nrddhxillnzlq01z"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-exception" ,perl-test-exception)))
+ (propagated-inputs
+ `(("perl-carp-assert" ,perl-carp-assert)))
+ (home-page "http://search.cpan.org/dist/Carp-Assert-More")
+ (synopsis "Convenience wrappers around Carp::Assert")
+ (description "Carp::Assert::More is a set of handy assertion functions for
+Perl.")
+ (license artistic2.0)))
+
(define-public perl-carp-clan
(package
(name "perl-carp-clan")