summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-12-23 18:14:25 +0100
committerLeo Famulari <leo@famulari.name>2020-12-24 15:19:02 -0500
commitfcdf4b4ec6192a81dd2a8b8fb58e1c0f3e91a4d9 (patch)
tree3ac9b78152b71d581230882017b9727d9a332c0e /gnu
parentc9120aa101cd4b881ac078acd6484bf3c5c431cc (diff)
downloadguix-patches-fcdf4b4ec6192a81dd2a8b8fb58e1c0f3e91a4d9.tar
guix-patches-fcdf4b4ec6192a81dd2a8b8fb58e1c0f3e91a4d9.tar.gz
gnu: Add libinih.
* gnu/packages/linux.scm (libinih): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 01f12f77d9..cb6332317c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7000,6 +7000,31 @@ communicate with the kernel. It can be used to add and remove interfaces, set
IP addresses and routes, and configure IPsec.")
(license license:asl2.0)))
+(define-public libinih
+ (package
+ (name "libinih")
+ (version "52")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/benhoyt/inih")
+ (commit (string-append "r" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0lsvm34zabvi1xlximybzvgc58zb90mm3b9babwxlqs05jy871m4"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:configure-flags '("-Ddistro_install=true" "-Ddefault_library=shared")))
+ (home-page "https://github.com/benhoyt/inih")
+ (synopsis "Simple .INI parser library for C")
+ (description "The inih (INI Not Invented Here) library is a simple .INI file
+parser written in C. It's only a couple of pages of code, and it was designed to
+be small and simple, so it's good for embedded systems. It's also more or less
+compatible with Python's ConfigParser style of .INI files, including RFC
+822-style multi-line syntax and name: value entries.")
+ (license license:bsd-3)))
+
(define-public xfsprogs
(package
(name "xfsprogs")