summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-12-24 12:41:17 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-12-24 12:42:41 +0100
commitf6e06e8b15d1fa6c17d8fd21f95b26985b4e1674 (patch)
tree25df951be4779a09f96686f151ff79b1a21426cd /gnu
parent20a687bbfbc72ffcd802b4bc59db344ad4291577 (diff)
downloadguix-patches-f6e06e8b15d1fa6c17d8fd21f95b26985b4e1674.tar
guix-patches-f6e06e8b15d1fa6c17d8fd21f95b26985b4e1674.tar.gz
gnu: opensmtpd: Update to 6.8.0p1.
* gnu/packages/mail.scm (opensmtpd): Update to 6.8.0p1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index f85713433e..a6de501b78 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2877,14 +2877,14 @@ from the Cyrus IMAP project.")
(define-public opensmtpd
(package
(name "opensmtpd")
- (version "6.7.1p1")
+ (version "6.8.0p1")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.opensmtpd.org/archives/"
"opensmtpd-" version ".tar.gz"))
(sha256
- (base32 "1jh8vxfajm1mvp1v5yh6llrhjzv0n9fgab88mlwllwqynhcfjy3l"))))
+ (base32 "10095dskwmrnsjkqvm2d08pws9jig7b88prbfr0qc5am49ggl8gm"))))
(build-system gnu-build-system)
(inputs
`(("bdb" ,bdb)
@@ -2911,19 +2911,27 @@ from the Cyrus IMAP project.")
;; See: https://github.com/OpenSMTPD/OpenSMTPD/issues/1069.
(add-after 'unpack 'fix-smtpctl-encrypt-bug
(lambda _
- (substitute* "smtpd/smtpctl.c"
+ (substitute* "usr.sbin/smtpd/smtpctl.c"
(("\"encrypt\", \"--\",")
"\"encrypt\","))
#t))
;; Fix some incorrectly hard-coded external tool file names.
(add-after 'unpack 'patch-FHS-file-names
(lambda _
- (substitute* "smtpd/smtpctl.c"
+ (substitute* "usr.sbin/smtpd/smtpctl.c"
;; ‘gzcat’ is auto-detected at compile time, but ‘cat’ isn't.
(("/bin/cat") (which "cat")))
- (substitute* "smtpd/mda_unpriv.c"
+ (substitute* "usr.sbin/smtpd/mda_unpriv.c"
(("/bin/sh") (which "sh")))
#t))
+ (add-after 'unpack 'fix-man-page-detection
+ ;; XXX Remove when https://github.com/OpenSMTPD/OpenSMTPD/pull/1113
+ ;; or similar fix is released.
+ (lambda _
+ (substitute* "configure"
+ (("smtpd/smtpd.8" match)
+ (string-append "usr.sbin/" match)))
+ #t))
;; OpenSMTPD provides a single smtpctl utility to control both the
;; daemon and the local submission subsystem. To accomodate systems
;; that require historical interfaces such as sendmail, newaliases or