summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-01-28 21:11:29 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-02-24 20:01:31 +0300
commitf3448f3ff8ee176e4ec080a12fa93a8a59f1e2f3 (patch)
treeea2d397c011f3128fcb8030ef0c86b1f1c6ca30e /gnu
parent222b50018de3ceb794b0abf7ef2c2466492cd81d (diff)
downloadguix-patches-f3448f3ff8ee176e4ec080a12fa93a8a59f1e2f3.tar
guix-patches-f3448f3ff8ee176e4ec080a12fa93a8a59f1e2f3.tar.gz
gnu: Add perl-strictures-2.
* gnu/packages/perl.scm (perl-strictures-2): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 983905bf54..2f976786d1 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7051,6 +7051,20 @@ on the length of the size.")
run from within a source-controlled directory.")
(license (package-license perl))))
+;; Some packages don't yet work with this newer version of ‘strictures’.
+(define-public perl-strictures-2
+ (package
+ (inherit perl-strictures)
+ (version "2.000003")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/H/HA/HAARG/"
+ "strictures-" version ".tar.gz"))
+ (sha256
+ (base32
+ "08mgvf1d2651gsg3jgjfs13878ndqa4ji8vfsda9f7jjd84ymy17"))))))
+
(define-public perl-string-camelcase
(package
(name "perl-string-camelcase")