summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-25 15:40:50 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:15:09 +0000
commitbce0a7d3d87222286176f1bdb49b3028cbc5e46b (patch)
tree77f770254ecf0f09cb7b5ad83fc12145df6f6a1e /gnu
parentbe58507d5d7f36da4c68bad2603c0a5b08858e1d (diff)
downloadguix-patches-bce0a7d3d87222286176f1bdb49b3028cbc5e46b.tar
guix-patches-bce0a7d3d87222286176f1bdb49b3028cbc5e46b.tar.gz
gnu: libproxy: Don't run tests when cross-compiling.
* gnu/packages/networking.scm (libproxy)[arguments]]<#:phases>{check}: Respect #:tests? when cross-compiling.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 532f2773df..c426c95e71 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Milkey Mouse <milkeymouse@meme.institute>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2253,8 +2254,13 @@ sockets in Perl.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "ctest" "-E" "url-test"))))))
+ ;; TODO(core-updates): Make this unconditional.
+ ,(if (%current-target-system)
+ '(lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "ctest" "-E" "url-test")))
+ '(lambda _
+ (invoke "ctest" "-E" "url-test")))))))
(synopsis "Library providing automatic proxy configuration management")
(description "Libproxy handles the details of HTTP/HTTPS proxy
configuration for applications across all scenarios. Applications using