summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-02 11:57:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-02 11:57:28 +0100
commita8fff63daa9a4dababac30826423d72e01a7b6c0 (patch)
treea45d0e416042f576d1caac69940a4f76543f5206 /gnu
parentb15a5257036251c92d3ed251ef654e16a7d6b553 (diff)
downloadguix-patches-a8fff63daa9a4dababac30826423d72e01a7b6c0.tar
guix-patches-a8fff63daa9a4dababac30826423d72e01a7b6c0.tar.gz
gnu: Add python-mygene.
* gnu/packages/bioinformatics.scm (python-mygene): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9cb2f1ed5d..c4da571f95 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10340,6 +10340,27 @@ single-cell RNA-seq data.")
API services.")
(license license:bsd-3)))
+(define-public python-mygene
+ (package
+ (name "python-mygene")
+ (version "3.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mygene" version))
+ (sha256
+ (base32 "1snszwdgfygchxshcbry3b5pbcw3g1isp8dw46razxccqaxwlag7"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-biothings-client" ,python-biothings-client)))
+ (home-page "https://github.com/biothings/mygene.py")
+ (synopsis "Python Client for MyGene.Info services.")
+ (description "MyGene.Info provides simple-to-use REST web services
+to query/retrieve gene annotation data. It's designed with simplicity
+and performance emphasized. Mygene is a Python wrapper to access
+MyGene.Info services.")
+ (license license:bsd-3)))
+
;; We cannot use the latest commit because it requires Java 9.
(define-public java-forester
(let ((commit "86b07efe302d5094b42deed9260f719a4c4ac2e6")