summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-04-18 11:26:30 +0200
committerLudovic Courtès <ludo@gnu.org>2016-04-18 11:26:30 +0200
commit940778c71c6be6987cf401a308261be6d33935a3 (patch)
treeab8b786e7bff4f25dda4fa471c71cb4406686aa7 /gnu
parenta7c61781df789183665dc7570e088ec11678a7db (diff)
downloadguix-patches-940778c71c6be6987cf401a308261be6d33935a3.tar
guix-patches-940778c71c6be6987cf401a308261be6d33935a3.tar.gz
gnu: ffmpeg: Re-add 2.8.6.
* gnu/packages/video.scm (ffmpeg-2.8): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 334f843abe..4907a4174f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -536,6 +536,26 @@ convert and stream audio and video. It includes the libavcodec
audio/video codec library.")
(license license:gpl2+)))
+(define-public ffmpeg-2.8
+ (package
+ (inherit ffmpeg)
+ (version "2.8.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1yh7dvm7zwdlsspdaq524s5qaggma5md9h95qc4kvb5dmyyyvg15"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments ffmpeg)
+ ((#:configure-flags flags)
+ `(map (lambda (flag)
+ (if (string=? flag "--disable-mipsdsp")
+ "--disable-mipsdspr1"
+ flag))
+ ,flags))))))
+
(define-public vlc
(package
(name "vlc")