summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-05-11 13:23:45 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-06-22 18:34:39 +0200
commit6f58ca5fb3c0abff168b2faa0a4edb8bde30f7a3 (patch)
tree9d33ae40ca38196c86099c0f4346a421a1cefedc /gnu
parentb994ff128bc33091db256bc40906aa5d4e670aa1 (diff)
downloadguix-patches-6f58ca5fb3c0abff168b2faa0a4edb8bde30f7a3.tar
guix-patches-6f58ca5fb3c0abff168b2faa0a4edb8bde30f7a3.tar.gz
gnu: Add emacs-packed.
* gnu/packages/emacs-xyz.scm (emacs-packed): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 26899f417b..eef33fd437 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -55,7 +55,7 @@
;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2019 Stephen Webber <montokapro@gmail.com>
-;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2019, 2021 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
@@ -20485,6 +20485,36 @@ e.g. the package dependencies it requires. See function
file.")
(license license:gpl3+)))
+(define-public emacs-packed
+ (package
+ (name "emacs-packed")
+ (version "3.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacscollective/packed")
+ (commit version)))
+ (sha256
+ (base32
+ "06blk8parnpq3qi6y5628q3v59c8dyi41glb289a0l16248qwphk"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/emacscollective/packed")
+ (synopsis "Package manager agnostic Emacs Lisp package utilities")
+ (description
+ "Packed provides some package manager agnostic utilities to work
+with Emacs Lisp packages. As far as Packed is concerned packages
+are collections of Emacs Lisp libraries that are stored in a
+dedicated directory such as a Git repository. And libraries are
+Emacs Lisp files that provide the correct feature (matching the
+filename).
+
+Where a package manager might depend on metadata, Packed instead
+uses some heuristics to get the same information---that is slower
+and might also fail at times but makes it unnecessary to maintain
+package recipes.")
+ (license license:gpl3+)))
+
(define-public emacs-picpocket
(let ((version "41")
(commit "fa3a49f011b5ae139728548fec7375743f61c7c7"))