summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-06-10 17:58:58 +0200
committerLeo Famulari <leo@famulari.name>2020-12-15 01:55:38 -0500
commit6655b975a0798a0473d23d134188fc39d8147b2c (patch)
tree0c06543b23ee7ab950a7e7dd0e0424c099df3396 /gnu
parentcfdad650b9f97604bc989f9a11fbd801bf8a2e93 (diff)
downloadguix-patches-6655b975a0798a0473d23d134188fc39d8147b2c.tar
guix-patches-6655b975a0798a0473d23d134188fc39d8147b2c.tar.gz
gnu: Add python-pywatchman.
* gnu/packages/python-xyz.scm (python-pywatchman): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9450e5770f..0f8fd4d270 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23307,3 +23307,24 @@ disk files in asyncio applications.")
"This is an implementation of PEP 557, Data Classes. It is a
backport of the @code{dataclasses} module for Python 3.6.")
(license license:asl2.0)))
+
+(define-public python-pywatchman
+ (package
+ (name "python-pywatchman")
+ (version "1.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pywatchman" version))
+ (sha256
+ (base32
+ "1yf2gm20wc3djpb5larxii3l55xxby0il2ns3q0v1byyfnr7w16h"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;there are none
+ (home-page
+ "https://facebook.github.io/watchman/")
+ (synopsis "Watchman client for python")
+ (description "@code{python-pywatchman} is a library to connect and
+query Watchman to discover file changes.")
+ (license license:bsd-3)))