summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-01-08 11:08:06 -0500
committerKei Kebreau <kkebreau@posteo.net>2018-01-09 11:43:34 -0500
commit1e257d3da9a43a0b4ad09ddfb32562a08122e7c0 (patch)
tree0e9910f4cca4e7d87ad1a388ff376cb0db6b04a7 /gnu
parent5b72dafe44625ad9844ec0fc38b315630fb99a12 (diff)
downloadguix-patches-1e257d3da9a43a0b4ad09ddfb32562a08122e7c0.tar
guix-patches-1e257d3da9a43a0b4ad09ddfb32562a08122e7c0.tar.gz
gnu: behave: Enable tests.
* gnu/packages/check.scm (behave)[native-inputs]: Add python-mock, python-nose and python-pyhamcrest. [arguments]: Remove #:tests?. Add #:test-target.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 76fb1dc3ff..50675cb854 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1549,12 +1549,16 @@ backported from Python 2.7 for Python 2.4+.")
(base32
"1iypp6z46r19n4xmgx6m1lwmlpfjh8vapq8izigrqlaarvp2y64c"))))
(build-system python-build-system)
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)
+ ("python-pyhamcrest" ,python-pyhamcrest)))
(propagated-inputs
`(("python-six" ,python-six)
("python-parse" ,python-parse)
("python-parse-type" ,python-parse-type)))
- (arguments `(#:tests? #f)) ;TODO: tests require nose>=1.3 and
- ;PyHamcrest>=1.8
+ (arguments
+ '(#:test-target "behave_test"))
(home-page "https://github.com/behave/behave")
(synopsis "Python behavior-driven development")
(description