summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-04-15 23:31:31 +0200
committerLudovic Courtès <ludo@gnu.org>2014-04-15 23:55:15 +0200
commit1da34f5ad5dff68b18d4d22002e48a61dc986881 (patch)
tree448258703d0332185057151e2fcfc4b4e5b3c3cd /gnu
parent158adb661175ed77694a56902a2e347a8192500f (diff)
downloadguix-patches-1da34f5ad5dff68b18d4d22002e48a61dc986881.tar
guix-patches-1da34f5ad5dff68b18d4d22002e48a61dc986881.tar.gz
gnu: Add tcpdump.
* gnu/packages/admin.scm (tcpdump): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 774194d87b..bc654dfc75 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -480,6 +480,31 @@ network statistics collection, security monitoring, network debugging, etc.")
;; fad-*.c and a couple other files are BSD-4, but the rest is BSD-3.
(license bsd-3)))
+(define-public tcpdump
+ (package
+ (name "tcpdump")
+ (version "4.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.tcpdump.org/release/tcpdump-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "15hb7zkzd66nag102qbv100hcnf7frglbkylmr8adwr8f5jkkaql"))))
+ (build-system gnu-build-system)
+ (inputs `(("libpcap" ,libpcap)))
+ (native-inputs `(("perl" ,perl))) ; for tests
+ (arguments
+ ;; XXX: Temporarily disabled until
+ ;; <https://github.com/the-tcpdump-group/tcpdump/issues/381> is resolved.
+ '(#:tests? #f))
+ (home-page "http://www.tcpdump.org/")
+ (synopsis "Network packet analyzer")
+ (description
+ "Tcpdump is a command-line tool to analyze network traffic passing
+through the network interface controller.")
+ (license bsd-3)))
+
(define-public jnettop
(package
(name "jnettop")