summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2017-11-10 14:22:28 +0100
committerJelle Licht <jlicht@fsfe.org>2017-11-10 14:22:28 +0100
commit177475cfb5318dbb2ecfd1a1df428c796bec299b (patch)
tree7a1567543227555f0ed962df1afcc5b245e3ed69 /gnu
parent011f57695a817f9b13c75e43069e572101a3edf7 (diff)
downloadguix-patches-177475cfb5318dbb2ecfd1a1df428c796bec299b.tar
guix-patches-177475cfb5318dbb2ecfd1a1df428c796bec299b.tar.gz
gnu: password-store: Install passmenu script.
* gnu/packages/password-utils (password-store) [inputs]: Add dmenu and xdotool. [arguments]<#:phases>['patch-passmenu-path']: New phase. [arguments]<#:phases>['install-passmenu']: New phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/password-utils.scm21
1 files changed, 19 insertions, 2 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 2fed93bf22..9b9bd163fd 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -54,6 +54,7 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages suckless)
#:use-module (gnu packages tls)
#:use-module (gnu packages qt)
#:use-module (gnu packages version-control)
@@ -344,6 +345,20 @@ any X11 window.")
(modify-phases %standard-phases
(delete 'configure)
(delete 'build)
+ (add-before 'install 'patch-passmenu-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "contrib/dmenu/passmenu"
+ (("dmenu") (string-append (assoc-ref inputs "dmenu")
+ "/bin/dmenu"))
+ (("xdotool") (string-append (assoc-ref inputs "xdotool")
+ "/bin/xdotool")))
+ #t))
+ (add-after 'install 'install-passmenu
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (copy-file "contrib/dmenu/passmenu"
+ (string-append out "/bin/passmenu"))
+ #t)))
(add-after 'install 'wrap-path
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -369,14 +384,16 @@ any X11 window.")
#:parallel-tests? #f
#:test-target "test"))
(inputs
- `(("getopt" ,util-linux)
+ `(("dmenu" ,dmenu)
+ ("getopt" ,util-linux)
("git" ,git)
("gnupg" ,gnupg)
("qrencode" ,qrencode)
("sed" ,sed)
("tree" ,tree)
("which" ,which)
- ("xclip" ,xclip)))
+ ("xclip" ,xclip)
+ ("xdotool" ,xdotool)))
(home-page "http://www.passwordstore.org/")
(synopsis "Encrypted password manager")
(description "Password-store is a password manager which uses GnuPG to